summaryrefslogtreecommitdiff
path: root/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild')
-rw-r--r--dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild b/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild
index 89622b4136e5..741726f9f8c9 100644
--- a/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild
+++ b/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Python classes to extract information from the Linux kernel /proc files"
HOMEPAGE="
- https://git.kernel.org/pub/scm/libs/python/python-linux-procfs/
- https://kernel.googlesource.com/pub/scm/libs/python/python-linux-procfs/python-linux-procfs/
+ https://git.kernel.org/pub/scm/libs/python/python-linux-procfs/python-linux-procfs.git/
"
SRC_URI="https://cdn.kernel.org/pub/software/libs/python/${PN}/${P}.tar.xz"
@@ -19,8 +18,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
python_test() {
- ${EPYTHON} ./bitmasklist_test.py || die "Tests failed with ${EPYTHON}"
+ "${EPYTHON}" ./bitmasklist_test.py || die "Tests failed with ${EPYTHON}"
}