summaryrefslogtreecommitdiff
path: root/dev-python/python-gnupg/python-gnupg-0.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-gnupg/python-gnupg-0.5.0.ebuild')
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.5.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/python-gnupg/python-gnupg-0.5.0.ebuild b/dev-python/python-gnupg/python-gnupg-0.5.0.ebuild
deleted file mode 100644
index 066044812645..000000000000
--- a/dev-python/python-gnupg/python-gnupg-0.5.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/vinaysajip.asc
-inherit distutils-r1 verify-sig
-
-DESCRIPTION="A Python wrapper for GnuPG"
-HOMEPAGE="
- https://docs.red-dove.com/python-gnupg/
- https://github.com/vsajip/python-gnupg/
- https://pypi.org/project/python-gnupg/
-"
-SRC_URI="https://github.com/vsajip/python-gnupg/releases/download/${PV}/${P}.tar.gz"
-SRC_URI+=" verify-sig? ( https://github.com/vsajip/python-gnupg/releases/download/${PV}/${P}.tar.gz.asc )"
-
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv sparc x86"
-LICENSE="BSD"
-SLOT="0"
-
-# Need gnupg[nls] for avoiding decode errors and possible hangs
-# w/ e.g. sec-keys/openpgp-keys-gentoo-developers but other pkgs too.
-RDEPEND="app-crypt/gnupg[nls]"
-DEPEND="${RDEPEND}"
-BDEPEND="verify-sig? ( sec-keys/openpgp-keys-vinaysajip )"
-
-distutils_enable_tests unittest
-
-python_test() {
- # NO_EXTERNAL_TESTS must be enabled,
- # to disable all tests, which need internet access.
- NO_EXTERNAL_TESTS=1 eunittest
-}