summaryrefslogtreecommitdiff
path: root/dev-python/python-gnupg/python-gnupg-0.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-gnupg/python-gnupg-0.4.0.ebuild')
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-gnupg/python-gnupg-0.4.0.ebuild b/dev-python/python-gnupg/python-gnupg-0.4.0.ebuild
new file mode 100644
index 000000000000..72c13fabebbc
--- /dev/null
+++ b/dev-python/python-gnupg/python-gnupg-0.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for GNU Privacy Guard"
+HOMEPAGE="http://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}"
+
+# They hung. We haven't figured out why yet.
+RESTRICT="test"
+
+python_test() {
+ # Note; 1 test fails under pypy only
+ "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
+}