summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest2
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-4.2.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index 5196987cd413..517865782344 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,3 +1,5 @@
DIST python-glanceclient-4.1.0.tar.gz 204252 BLAKE2B 484753886663f10b93fc2d9a0c3c2a1359324d989edfa26c0fe26cb7ab74897a5a81a3fac201d53af375d111e0b1e043fce79b1f3d3f153854bd9f63db756a9f SHA512 413d5a77c4b014f6300513552aca33a04e9a34e9bfa9c93ecc9008c79123ba7f20e527f3ad7506d066c0d215aa7fbf57a589a5f015fe1bc52479b8c57c760adf
+DIST python-glanceclient-4.2.0.tar.gz 204378 BLAKE2B ee869971f769dd01da2dcf7e1d7ca07e120b5a2ad5a210db7b6cf813a0bb14bb00f8d7f64a4a5c03de61983abfad0448ff3ad9ab4b9acb485a897ae39e4c9409 SHA512 4977db9650ec35ad663fdaa9c576fb1c63efddb9f3df8a92da9e97e530bb5a63016e2492f81239fbb4d01cf260e673c2d489566c10483d2bf6ff9e0653e3bd21
EBUILD python-glanceclient-4.1.0.ebuild 1465 BLAKE2B 2c6105ab1bf72665b04a5bf9cfad8b3e1c52191f5693925e1c6d75fc34723fdc0efb2af6d6781219a056b0f4a35f86c4a75927a7ba6f74aac79e37690066089f SHA512 dbf4f872de33874d58b0bf44a248701127c4f19f39800bb2694cc480fde4688055cba4ff64bfde1092f4fefa747802d630c16e0e5905a47e372b9129e2f3cfa0
+EBUILD python-glanceclient-4.2.0.ebuild 1517 BLAKE2B 52aa18bcbb236fb27380d67ba3baeb5a26dea97a022c564a671e9c9eb260530a4fb66f97a27f8a7ed9905b1edbef82f7149f4f6c623abc024c295735a62a2d4a SHA512 6fc6bc8992d21eade094a2551a6f181c345e00f05ffc3936ba002862e55bf3b548c51fd7528aefc0c58340e517a39a0bc682f9ba8c3f77f3e1494a4d4bc620eb
MISC metadata.xml 663 BLAKE2B 642540f3f4d577797725731f2374b5801ec2d4ad799ee4ccfaa4e29d955bd93a8ade0e6c9ec7712ee27d9f1f93186854472d301016a732020575b8f7bc1c5138 SHA512 fa9b88dce5a10824dd0d6987698587666343c95d8b6c607e466f14883c34fb0ebc846b683ae7d8bb65efe88007e6db0d2b1b41ba389c3b656a24f1839d03d9e2
diff --git a/dev-python/python-glanceclient/python-glanceclient-4.2.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-4.2.0.ebuild
new file mode 100644
index 000000000000..cad3bc6a49c5
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-4.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-glanceclient/
+ https://github.com/openstack/python-glanceclient/
+ https://pypi.org/project/python-glanceclient/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b glanceclient/tests/unit
+}