summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest2
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-4.7.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index d5737890cea4..6c4965095c85 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,5 +1,7 @@
AUX python-glanceclient-4.6.0-test-py3.13.patch 3309 BLAKE2B 10d1b031f0cc4014cb4a7027b4d7af5f3f271cc3bf7e7dc8222a9e81cb93e2e2351e1812d3a371da9eba09ae7eac39b9492005b2ca341849cb8820591c7abc7d SHA512 cd699eacd600df4aabdb67ec7017419023d48bbdef25909326bd722c0b8a8b4291edc71090ae32b2207e8fb1f2b0a2dd2c6de46dda50ddad11e40c510d1dd87e
AUX python-glanceclient-4.6.0-test.patch 4172 BLAKE2B 3b2d7c7e132cb3a71e1be0f9a6306915ab757d83e814b88acec0a45f8bb44d0c22e428094c03dd6bdf786c12276883412cd979560fa33129039631429ae4aaa9 SHA512 75b5f8a1f85ae68f330d4c8370b06ac3be5f09285df4c608469b00f815332ec38de337075ad4053c64044bc2d2fe6e0d1ebf461aae81385888a344c24fc82bbc
DIST python-glanceclient-4.6.0.tar.gz 206480 BLAKE2B 302414b0fcf85ec9a8e53e9bf43c5801df82826524780249e9c4b46b44ca2e53c1c5d63f6e80c73dee2a59009a3e0aa1df591ecb2a4d000b74ee078b4810de2c SHA512 ed9d554d40a03134bc8871fbf712dd4bb2aab5e18854fd9c07df0d20dead1a9f3473bc4253ba4dd8c87cf7227148c637718461d45cd01bd9aaf673f7fc7ee9fc
+DIST python-glanceclient-4.7.0.tar.gz 208314 BLAKE2B 97a157781efc0fc67d67f25119edea2a3f85344447e4614f41c73a3f9abda1c9ba646ca7f8d7b2b315b4572997ec730e6eef1782852590e7021f69c61b02920b SHA512 5fff50d499b7fe439cb43c7d396a7dd28439f45cfc157e4fdefb029e7db4cc9955911aae9c4d748fc19bd10ad66d299e26a1178a63a866fef7fb60164467c79d
EBUILD python-glanceclient-4.6.0.ebuild 1785 BLAKE2B 19c84066ca8e55d86f03b7985d7edba8baa5dabc165d937dfecceb884931794ac246886aa2f15d00c47b80eccd3a5485af37696e370478a131c462ddde489185 SHA512 0aa7dbfd4704294b5ed1bfc5b60732bfbc7438a8c5cc7b801c7641f48583f6d9852a90e769418f64d5ed1ee4da40175bad0b20549eb47d8d339f7e319d819abd
+EBUILD python-glanceclient-4.7.0.ebuild 1802 BLAKE2B 8b26df08b619aee4fbf7aa3f969b4fba9e48d3b20903050b7f6e93882359a0a5abdac97604645e2e92326f50917358820eb95445315047c90bb1a8f310a45ac2 SHA512 41d596175595fbdd0217cad5e0de6104144ebc997dd4b78e965b6be1cc4f402c36bfe95de478f88bcb905e4c3aa59b717513a2739b59a14c0c1210d8138f5960
MISC metadata.xml 663 BLAKE2B 642540f3f4d577797725731f2374b5801ec2d4ad799ee4ccfaa4e29d955bd93a8ade0e6c9ec7712ee27d9f1f93186854472d301016a732020575b8f7bc1c5138 SHA512 fa9b88dce5a10824dd0d6987698587666343c95d8b6c607e466f14883c34fb0ebc846b683ae7d8bb65efe88007e6db0d2b1b41ba389c3b656a24f1839d03d9e2
diff --git a/dev-python/python-glanceclient/python-glanceclient-4.7.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-4.7.0.ebuild
new file mode 100644
index 000000000000..ddd1c184c14b
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-4.7.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-glanceclient/
+ https://github.com/openstack/python-glanceclient/
+ https://pypi.org/project/python-glanceclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth1-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ # combined patch for urllib3-2 and py3.12 test failures
+ # https://bugs.launchpad.net/python-glanceclient/+bug/2069684
+ # https://bugs.launchpad.net/python-glanceclient/+bug/2069682
+ "${FILESDIR}/${PN}-4.6.0-test.patch"
+
+ # py3.13 added close() to mock_open calls
+ # https://review.opendev.org/c/openstack/python-glanceclient/+/923628
+ "${FILESDIR}/${PN}-4.6.0-test-py3.13.patch"
+)
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b glanceclient/tests/unit
+}