summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild')
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild
index b4327bb76bde..885408a4fbdc 100644
--- a/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild
+++ b/dev-python/python-glanceclient/python-glanceclient-2.16.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -25,7 +25,6 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/coverage-4.0[${PYTHON_USEDEP}]
!~dev-python/coverage-4.4[${PYTHON_USEDEP}]
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/ordereddict-1.1[$(python_gen_usedep 'python2_7')]
>=dev-python/os-client-config-1.28.0[${PYTHON_USEDEP}]
>=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
>=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
@@ -58,6 +57,6 @@ python_prepare_all() {
python_test() {
testr init
- testr run || die "testsuite failed under python2.7"
+ testr run || die "testsuite failed under ${EPYTHON}"
flake8 tests && einfo "run flake8 over tests folder passed" || die
}