summaryrefslogtreecommitdiff
path: root/dev-python/python-gflags/python-gflags-3.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-gflags/python-gflags-3.1.2.ebuild')
-rw-r--r--dev-python/python-gflags/python-gflags-3.1.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-gflags/python-gflags-3.1.2.ebuild b/dev-python/python-gflags/python-gflags-3.1.2.ebuild
new file mode 100644
index 000000000000..fbe985dcaf55
--- /dev/null
+++ b/dev-python/python-gflags/python-gflags-3.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google's Python argument parsing library"
+HOMEPAGE="https://github.com/google/python-gflags"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-script-install.patch
+)
+
+python_test() {
+ # note: each test needs to be run separately, otherwise they fail
+ "${PYTHON}" -m gflags._helpers_test -v || die
+ "${PYTHON}" -m gflags.flags_formatting_test -v || die
+ "${PYTHON}" -m gflags.flags_unicode_literals_test -v || die
+}