summaryrefslogtreecommitdiff
path: root/dev-python/python-gammu/python-gammu-2.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-gammu/python-gammu-2.11.ebuild')
-rw-r--r--dev-python/python-gammu/python-gammu-2.11.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-gammu/python-gammu-2.11.ebuild b/dev-python/python-gammu/python-gammu-2.11.ebuild
new file mode 100644
index 000000000000..7c6896eb4176
--- /dev/null
+++ b/dev-python/python-gammu/python-gammu-2.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Gammu"
+HOMEPAGE="https://wammu.eu/python-gammu/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=">=app-mobilephone/gammu-1.34.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ $(python_gen_impl_dep sqlite)
+ app-mobilephone/gammu[dbi]
+ )"
+
+DOCS=( AUTHORS NEWS.rst README.rst )
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}