summaryrefslogtreecommitdiff
path: root/dev-python/python-dotenv/files/python-dotenv-0.19.2-entry-points.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-dotenv/files/python-dotenv-0.19.2-entry-points.patch')
-rw-r--r--dev-python/python-dotenv/files/python-dotenv-0.19.2-entry-points.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-dotenv/files/python-dotenv-0.19.2-entry-points.patch b/dev-python/python-dotenv/files/python-dotenv-0.19.2-entry-points.patch
new file mode 100644
index 000000000000..a01806fbc8c1
--- /dev/null
+++ b/dev-python/python-dotenv/files/python-dotenv-0.19.2-entry-points.patch
@@ -0,0 +1,21 @@
+diff --git a/setup.py b/setup.py
+index a8122d3..c7bfe82 100644
+--- a/setup.py
++++ b/setup.py
+@@ -36,10 +36,12 @@ setup(
+ extras_require={
+ 'cli': ['click>=5.0', ],
+ },
+- entry_points='''
+- [console_scripts]
+- dotenv=dotenv.cli:cli
+- ''',
++ entry_points={
++ "console_scripts": [
++ "dotenv=dotenv.cli:cli",
++ "python-dotenv=dotenv.cli:cli",
++ ],
++ },
+ license='BSD-3-Clause',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',