summaryrefslogtreecommitdiff
path: root/dev-python/python-dbusmock/python-dbusmock-0.28.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-dbusmock/python-dbusmock-0.28.0.ebuild')
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.28.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.28.0.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.28.0.ebuild
deleted file mode 100644
index 7b67a06c46ee..000000000000
--- a/dev-python/python-dbusmock/python-dbusmock-0.28.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Easily create mock objects on D-Bus for software testing"
-HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
-SRC_URI="
- https://github.com/martinpitt/python-dbusmock/releases/download/${PV}/${P}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # needed for unittest discovery
- > tests/__init__.py || die
- # linter tests, fragile to newer linter versions
- rm tests/test_code.py || die
-
- distutils-r1_src_prepare
-}