summaryrefslogtreecommitdiff
path: root/dev-python/python-cinderclient
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/Manifest2
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-9.5.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index e86f2e8c9f17..a231e1830811 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1,3 +1,5 @@
DIST python-cinderclient-9.4.0.tar.gz 236451 BLAKE2B 75d5ee0c3f64c3254e7f9f806bccc685ab929c5812076fb7b78a995e9c9adbf384f296799f7119128e1781a34e727e305e3ae4bef04939adc2e7fd0268e83b1c SHA512 e7628b569bf46c7a8d5ecf7918be9133b400411d5509112baad49f7ff60ad0fc5d7c98cec9d4d6286cf8bd9c23c918af3aaa52c1b2d68536a3a2e4a89ce8502b
+DIST python-cinderclient-9.5.0.tar.gz 236811 BLAKE2B 60d450ea31357d366c0c18b6715a36f51a9700393c2e5bb0967cd86706dd552fb2deaee428816019e87bd2c272b2f9342118b1f770370ce5aba062d3ebd292ce SHA512 efcc0f4b32e1d6f8d696137c416aeed6fc4f2a69b6fa59d47f0c46dc7d38d1f2bbc5ea35d1bcbac0604e9db8b75d256d47a76d17d040b6e84fca6069a65df8d8
EBUILD python-cinderclient-9.4.0.ebuild 1272 BLAKE2B f398f805ef2af5b386b1b396f4fc27c1461006176603579d02aacfe484079079b5c9e2c9d7f38bf4368cb5cb24c5e61ccfb5dd85a2dbcfb46d038986094d1bcb SHA512 c92922e6435e1abd75469eb15323fda7a4d9d90d48883cd2765c5139ce8d7707fb7f8a51e43895e068db7b0ebba2ec3351775b72113d0e0ace602e75349c2a3c
+EBUILD python-cinderclient-9.5.0.ebuild 1275 BLAKE2B 30df52bfe14c91fe586c5fa7435d95315a6d875258eac69ddd0915241af32c6304b959916a607dd17f56d8a638df028493327e54294e6cd45ded7b36a24dd345 SHA512 0758dc8bd99d4cae30a6edab7ad249e13cc84b826bf431936a6886038e8f78f1ebddc2f316ab658ffea9adc036d8f6fd4e85bfbc12262ef1f15f2d8a7ca36ef4
MISC metadata.xml 727 BLAKE2B 0017cc08edf25f27b8a2816bc3ce1374148a17522bf2c5ea643ad10cde9f5779b1b6bf1e3c91627db76d2f77b8dcbfc87a29fb2cdd8064b3140fb14d1e6e00a1 SHA512 e30e64371f7a5f5fa506396f2edbbc7f862a585c7fe9af4f6fe63e99d4bbe9f9bf3a1f002a62c40ab9d75bd90ab99446bb80bf7f2fedf5b37287eeb54e5dacbe
diff --git a/dev-python/python-cinderclient/python-cinderclient-9.5.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-9.5.0.ebuild
new file mode 100644
index 000000000000..cab20f180eb5
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-9.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-cinderclient/
+ https://github.com/openstack/python-cinderclient/
+ https://pypi.org/project/python-cinderclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth1-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/oslo-serialization[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b cinderclient/tests/unit
+}