summaryrefslogtreecommitdiff
path: root/dev-python/pytest_jupyter/pytest_jupyter-0.6.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest_jupyter/pytest_jupyter-0.6.2.ebuild')
-rw-r--r--dev-python/pytest_jupyter/pytest_jupyter-0.6.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest_jupyter/pytest_jupyter-0.6.2.ebuild b/dev-python/pytest_jupyter/pytest_jupyter-0.6.2.ebuild
new file mode 100644
index 000000000000..78d14293f4a7
--- /dev/null
+++ b/dev-python/pytest_jupyter/pytest_jupyter-0.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+
+RDEPEND="
+ >=dev-python/jupyter_client-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.21[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest