summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xvfb
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-xvfb')
-rw-r--r--dev-python/pytest-xvfb/Manifest2
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild10
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/pytest-xvfb/Manifest b/dev-python/pytest-xvfb/Manifest
index 8b60a22a1aa2..f7a1ad61152b 100644
--- a/dev-python/pytest-xvfb/Manifest
+++ b/dev-python/pytest-xvfb/Manifest
@@ -1,3 +1,3 @@
DIST pytest-xvfb-2.0.0.tar.gz 6855 BLAKE2B 338802ccbf5fc0c9ab3fccd7c172b31867cc86869dfc50dbb30daf396ecd9865e71c6486cc96c2485e2d5b6195dc2eff83a033864f88e1b2c64a3937b6b48c84 SHA512 42c2119b2c529a45b5de9f8ac2781306cfb9f00c1d0e0e9045ed40ccb7260cb6f400683802ab845ce2481dcadfcef007c8417a481e9c04f14ee1bdc68244d391
-EBUILD pytest-xvfb-2.0.0.ebuild 676 BLAKE2B bbf3af62b15434d9564a49d94ecdc155d63e8eeb1a8f37434ab45c8b44471ab32af0ab80c0f3e3379d2f4b42e3fd8da1fe88d6f22898c5a4e6526039f67fe0d8 SHA512 9fc13d53cf326ecda6af83ae73fd353060e4b1435952ba814493ffcd43c3d561690d07034f4f8c40fbb86bb653e37a966c7d124ee37f0a5033d9d0590dfd900c
+EBUILD pytest-xvfb-2.0.0.ebuild 765 BLAKE2B 56d9422573ae2d082f6726f9d5ee5845b2d833cf7b21731df5c16e0fcd6693e231215b55260fa7997b78e135f6b19185e1ee2d7d34730f2389db405fa6d7bd98 SHA512 e00ff840b4009968b0a9c73466eba0e7e6df57e9facf02cb294eb852db00bb89c1397e0a1ec72d9f2bc1910160e13e044d1aee43aeda63d96d48eb00f605d978
MISC metadata.xml 375 BLAKE2B 393138e315b4eae4dacb9339fbb5766e9dbaa84b7482babaddc08d524fb8b9939f6622ee9c6d09b66c61ac270fcc483fac39996a12ba87ccccf7cafd4c6d36db SHA512 9a44b6b9de4d1a61d6af9256519473541d5513cef349c15178c025dee3aaaa3f6772b1be56576411a985fcd9c70029c00743d8f577be8eaec4c5a44646c9cbf6
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
index af48d69b6055..e6d752d53f87 100644
--- a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
+++ b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/The-Compiler/pytest-xvfb/archive/v${PV}.tar.gz -> ${
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
DEPEND="
>=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
@@ -24,6 +24,10 @@ DEPEND="
distutils_enable_tests pytest
python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests failed with ${EPYTHON}"
+ local -x PYTHONPATH="${BUILD_DIR}/install/lib"
+ esetup.py install \
+ --root="${BUILD_DIR}/install" \
+ --install-lib=lib
+
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}