summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xvfb
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-xvfb')
-rw-r--r--dev-python/pytest-xvfb/Manifest3
-rw-r--r--dev-python/pytest-xvfb/metadata.xml1
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r1.ebuild34
3 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/pytest-xvfb/Manifest b/dev-python/pytest-xvfb/Manifest
index 33def591620d..bd251aaaf839 100644
--- a/dev-python/pytest-xvfb/Manifest
+++ b/dev-python/pytest-xvfb/Manifest
@@ -1,3 +1,4 @@
DIST pytest-xvfb-2.0.0.tar.gz 6855 BLAKE2B 338802ccbf5fc0c9ab3fccd7c172b31867cc86869dfc50dbb30daf396ecd9865e71c6486cc96c2485e2d5b6195dc2eff83a033864f88e1b2c64a3937b6b48c84 SHA512 42c2119b2c529a45b5de9f8ac2781306cfb9f00c1d0e0e9045ed40ccb7260cb6f400683802ab845ce2481dcadfcef007c8417a481e9c04f14ee1bdc68244d391
+EBUILD pytest-xvfb-2.0.0-r1.ebuild 790 BLAKE2B 1bc599cd756084cf834f24576198d9d33befcf0cdaa499d7627edcf713c294c6c05acf46b82f2ac959a3e600ac3695aa3e459bfcf3d86cf5d8db5c6b22fefcf2 SHA512 82503d49f45e884260476b3daec2d32914c631c5142a314885bd43ff2b8a500d43e99badecbd1eab5395ea3781d93940751e0bb573985b3dce94e810b97f656c
EBUILD pytest-xvfb-2.0.0.ebuild 765 BLAKE2B 56d9422573ae2d082f6726f9d5ee5845b2d833cf7b21731df5c16e0fcd6693e231215b55260fa7997b78e135f6b19185e1ee2d7d34730f2389db405fa6d7bd98 SHA512 e00ff840b4009968b0a9c73466eba0e7e6df57e9facf02cb294eb852db00bb89c1397e0a1ec72d9f2bc1910160e13e044d1aee43aeda63d96d48eb00f605d978
-MISC metadata.xml 479 BLAKE2B 1d0427df88aa1f23e585453431eaa90b7deb013c5a48782221dac97946437a8a79d785e3d7f01c6d8272a51917e509655d44e3794fe08e6e676bba37804c484b SHA512 16b9efc376d0aad8e3db0982d616c413c01d26f1e44756a4e02ea68b999dfa457e5eea47d6fbb675fe68096fd780a4c1945f2554922846c0559baafe0fbc357c
+MISC metadata.xml 503 BLAKE2B 33c6a351d0be7742f11a036b78799e31ce87bd91cbbbdc6017c272a83d8008bf4ec19df12a0152a8b9918196aa17e10a84729efa645b8a7421ae7875d7acde64 SHA512 2d87f0fdc631538f2a3f9afc933ae44c0957c03f4b7e57291f902c3deef3b7f087a2ab2651a224c9868f61e9e37a00ef267a5f2b07a43dbb253f3938a4990f30
diff --git a/dev-python/pytest-xvfb/metadata.xml b/dev-python/pytest-xvfb/metadata.xml
index 8762625bd5df..c5489072fff3 100644
--- a/dev-python/pytest-xvfb/metadata.xml
+++ b/dev-python/pytest-xvfb/metadata.xml
@@ -9,6 +9,7 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">pytest-xvfb</remote-id>
</upstream>
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r1.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..413aadefb50b
--- /dev/null
+++ b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_REQ_USE="tk"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pytest plugin to run Xvfb for tests"
+HOMEPAGE="https://pypi.org/project/pytest-xvfb/"
+SRC_URI="https://github.com/The-Compiler/pytest-xvfb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pyvirtualdisplay-1.3[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTHONPATH="${BUILD_DIR}/install/lib"
+ esetup.py install \
+ --root="${BUILD_DIR}/install" \
+ --install-lib=lib
+
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}