summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xprocess/pytest-xprocess-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-xprocess/pytest-xprocess-1.0.1.ebuild')
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-1.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-1.0.1.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-1.0.1.ebuild
new file mode 100644
index 000000000000..7ed4e7ad9828
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xprocess/
+ https://github.com/pytest-dev/pytest-xprocess/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest