summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist/pytest-xdist-3.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-xdist/pytest-xdist-3.2.0.ebuild')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.2.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.2.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.2.0.ebuild
deleted file mode 100644
index c3bc7d37a95e..000000000000
--- a/dev-python/pytest-xdist/pytest-xdist-3.2.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Distributed testing and loop-on-failing modes"
-HOMEPAGE="
- https://pypi.org/project/pytest-xdist/
- https://github.com/pytest-dev/pytest-xdist/
-"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- dev-python/execnet[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/filelock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # disable autoloading plugins in nested pytest calls
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # since we disabled autoloading, force loading necessary plugins
- local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
-
- epytest
-}