summaryrefslogtreecommitdiff
path: root/dev-python/pytest-testmon/pytest-testmon-1.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-testmon/pytest-testmon-1.0.3.ebuild')
-rw-r--r--dev-python/pytest-testmon/pytest-testmon-1.0.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-testmon/pytest-testmon-1.0.3.ebuild b/dev-python/pytest-testmon/pytest-testmon-1.0.3.ebuild
new file mode 100644
index 000000000000..18df13a7d277
--- /dev/null
+++ b/dev-python/pytest-testmon/pytest-testmon-1.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Take TDD to a new level with py.test and testmon"
+HOMEPAGE="https://github.com/tarpas/pytest-testmon"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Tests are broken for version 1.0.3
+# https://github.com/tarpas/pytest-testmon/issues/158
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/unittest-mixins[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest