summaryrefslogtreecommitdiff
path: root/dev-python/pytest-testinfra
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest4
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-10.1.0.ebuild54
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-10.1.1.ebuild2
3 files changed, 2 insertions, 58 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index 936c22d1ca21..519336f6d008 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-testinfra-10.1.0.tar.gz 85117 BLAKE2B 3db43661def60ef9627bd888b92f409886f2d6f1ae1306a8d46bbcbe3363cf5ae9e79f9fab49f0d0f8d6529d677a40db04fc68597d0d11e0285a7e27a01283fb SHA512 98003ab250c06fc69ff015fc53af87aa642109866a86bdd679cc8876db614660f11f79c3146aef10c7b8f47723a13777cbad07276af661986129a5d0bfc11e1b
DIST pytest-testinfra-10.1.1.tar.gz 86567 BLAKE2B b9dd9ea4023b1b7d9399615fbf6493efb094ec7f2478f65b46118173f6b20f545b645d06f20b42544325d68a917812a55f902ca28774b8ffb8743ac8182c3970 SHA512 6173937b03eaefb84a95b6fca616092ea0649f880fd1bccef6364f338b859bda8d09d706b517625b81cff4f663ababa766dac82d4d094c38683d9b170909f6c9
-EBUILD pytest-testinfra-10.1.0.ebuild 1250 BLAKE2B 294debb7495677ab384cc0f8b02a9ba2f6c4ba45cb74607da0ea9457be29514c79059252b3905d6cff2a9fbd2d5739b977bdc059a15552357cb3768e2e79c818 SHA512 5452af12f170b7f4ad630e3f64e4a7c9c0d81841c28385cbea5effd2d058c4bf36051ef9286a63dcece661db6e18794983e4fdf1401a1b2375eb23d3173bcecf
-EBUILD pytest-testinfra-10.1.1.ebuild 1252 BLAKE2B e3b5c6b3e54d52d9924cf6c0a7272d56f7efeee750265823dd9d4c5801d0f60985d7100f23994611683ab764df495226fa54d191761580836fb55aa0ce788b97 SHA512 f7e31e08230ceabffc8b6549bec86edaee70e8a97097c93915598d9101292afdc541f4ec3b2a62840d1dabcdff65658a27f3adace0f29a27c4583d8c72af327c
+EBUILD pytest-testinfra-10.1.1.ebuild 1250 BLAKE2B 294debb7495677ab384cc0f8b02a9ba2f6c4ba45cb74607da0ea9457be29514c79059252b3905d6cff2a9fbd2d5739b977bdc059a15552357cb3768e2e79c818 SHA512 5452af12f170b7f4ad630e3f64e4a7c9c0d81841c28385cbea5effd2d058c4bf36051ef9286a63dcece661db6e18794983e4fdf1401a1b2375eb23d3173bcecf
MISC metadata.xml 781 BLAKE2B e38dd6fa967258affb201d6474524e22124a1b8848cff08f3da88e97ff3e13597770c494ee040481967028ee4d82112fb3d38f1034cb7982288d859efe540a21 SHA512 b6c868e77d1202622086340ae284071eaf1b95948c84a8a00f06e819e72325346d7aa226931d1bb5a3f782f23656c1e65f4b21a74ee0cb70deabfd602f774e99
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-10.1.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-10.1.0.ebuild
deleted file mode 100644
index 6a6eef4cb700..000000000000
--- a/dev-python/pytest-testinfra/pytest-testinfra-10.1.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Write unit tests in Python to test actual state of your servers"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-testinfra/
- https://pypi.org/project/pytest-testinfra/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~riscv"
-
-RDEPEND="
- dev-python/pytest[${PYTHON_USEDEP}]
-"
-# Ansible is called via its CLI
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- app-admin/ansible
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/pywinrm[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x EPYTEST_DESELECT=()
-
- # This is the only test which actually fails if salt cannot be imported
- if ! has_version "dev-python/salt[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- test/test_backends.py::test_backend_importables
- )
- fi
-
- epytest
-}
-
-pkg_postinst() {
- elog "For the list of available connection back-ends and their dependencies,"
- elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
-}
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-10.1.1.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-10.1.1.ebuild
index 382fca67b309..6a6eef4cb700 100644
--- a/dev-python/pytest-testinfra/pytest-testinfra-10.1.1.ebuild
+++ b/dev-python/pytest-testinfra/pytest-testinfra-10.1.1.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv"
+KEYWORDS="amd64 arm64 ~riscv"
RDEPEND="
dev-python/pytest[${PYTHON_USEDEP}]