summaryrefslogtreecommitdiff
path: root/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild')
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild
new file mode 100644
index 000000000000..8081571a974a
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="https://github.com/pytest-dev/pytest-testinfra"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible[${PYTHON_USEDEP}]
+ app-admin/salt[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}