summaryrefslogtreecommitdiff
path: root/dev-python/pytest-system-statistics
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-system-statistics')
-rw-r--r--dev-python/pytest-system-statistics/Manifest2
-rw-r--r--dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild20
2 files changed, 9 insertions, 13 deletions
diff --git a/dev-python/pytest-system-statistics/Manifest b/dev-python/pytest-system-statistics/Manifest
index 1e7d5e7afc12..e061dd52c6fb 100644
--- a/dev-python/pytest-system-statistics/Manifest
+++ b/dev-python/pytest-system-statistics/Manifest
@@ -1,4 +1,4 @@
AUX pytest-system-statistics-1.0.2-loader.patch 1940 BLAKE2B 1e7e9738d928c72881b7e67715eefe898ced9d1031bc93a9fe899199143dd29d51361a24187fda9e41bc4ee892d7bfdd2ffbb290baf915ba287a546f56c9a34d SHA512 bfbd78c791123fdabd6e2c2c7a8d8ca71488c61a8767d450b8a72fc81a42ec2db9e9c079938f847fb3b5aa33a0ac4bb872c957c1c98e1b6fcd41e403aee4b5c0
DIST pytest-system-statistics-1.0.2.gh.tar.gz 55147 BLAKE2B 9b1217102a23e723090e04652fdd727818e2404bf110e4f54289251eb92f4abb59861ba6c6fc611c843960cf0595fa5cbd636071033327d4e602606e8ab63abf SHA512 1fab5038dde504ab0d5d0f4da851c9a8260849adb38a1196c6399131d77cc24a1926e68310dd0701ed001a20a7fcfb57c5202c5ebfd6de4c85aac4be49fc7347
-EBUILD pytest-system-statistics-1.0.2-r2.ebuild 1500 BLAKE2B 73bca81eef38e1238a7a9a18e702c0e1eb4179d3c1e0d6161f2858ed5b17a9abe215d052414b80b8ca3678627bfc483a76aef86b546daeba0261082ae42ef5ca SHA512 2631b11f95fcb0d8dbc11419ef44afae38c99b0c2dc1bfaa994c9574bfe8fd4bb0185ab6ef16e214270e259effc2ddedb05b446927b8eb6f7040ea9b75b740ca
+EBUILD pytest-system-statistics-1.0.2-r2.ebuild 1246 BLAKE2B df85e742af26d5894ffbea00ceafe0abf92fb373e718b09e25034c005f970074892730d5b943afdb161da5c861fe8621a83273fc62d5ccc9322d77432e5c9179 SHA512 4946964babd17dc869605320a5f318b91b71641fbd846f446284083d72b92053149b063942e5f4e87645b58f3661a3f85eaa241e55357311be643d3a1986a074
MISC metadata.xml 411 BLAKE2B 62a26b77897804129bdc4adecf7d0d6300b94ad2480530e2a191ae7243e56391adcc6510ca10d592d7862c7b285508b8d4b8bfa52b80f3e909de0edb4b546e90 SHA512 36d8ee496b98f7ff9982389992b10b4d3d0fb5cfba58ec00d49758ac438697846e9751a0d3651834f6c8796e313f58860cc55283b1a51c3ec065fca04c84dc28
diff --git a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild
index 24f261c75ef4..33ba05c24c2e 100644
--- a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild
+++ b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild
@@ -4,7 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Pytest Plugin Which Reports System Usage Statistics"
@@ -12,7 +13,10 @@ HOMEPAGE="
https://pypi.org/project/pytest-system-statistics/
https://github.com/saltstack/pytest-system-statistics
"
-SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+SRC_URI="
+ https://github.com/saltstack/pytest-system-statistics/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="Apache-2.0"
SLOT="0"
@@ -26,7 +30,7 @@ RDEPEND="
dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-python/pytest-subtests[${PYTHON_USEDEP}]
)
@@ -38,15 +42,7 @@ PATCHES=(
distutils_enable_tests pytest
-python_prepare_all() {
- sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
- sed -e "/setuptools_scm/ d" -i setup.cfg || die
- sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
-
- printf '__version__ = "${PV}"\n' > src/pytestsysstats/version.py || die
-
- distutils-r1_python_prepare_all
-}
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
python_test() {
local EPYTEST_DESELECT=(