summaryrefslogtreecommitdiff
path: root/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild')
-rw-r--r--dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild
index 24f261c75ef4..33ba05c24c2e 100644
--- a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild
+++ b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2-r2.ebuild
@@ -4,7 +4,8 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Pytest Plugin Which Reports System Usage Statistics"
@@ -12,7 +13,10 @@ HOMEPAGE="
https://pypi.org/project/pytest-system-statistics/
https://github.com/saltstack/pytest-system-statistics
"
-SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+SRC_URI="
+ https://github.com/saltstack/pytest-system-statistics/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="Apache-2.0"
SLOT="0"
@@ -26,7 +30,7 @@ RDEPEND="
dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-python/pytest-subtests[${PYTHON_USEDEP}]
)
@@ -38,15 +42,7 @@ PATCHES=(
distutils_enable_tests pytest
-python_prepare_all() {
- sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
- sed -e "/setuptools_scm/ d" -i setup.cfg || die
- sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
-
- printf '__version__ = "${PV}"\n' > src/pytestsysstats/version.py || die
-
- distutils-r1_python_prepare_all
-}
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
python_test() {
local EPYTEST_DESELECT=(