summaryrefslogtreecommitdiff
path: root/dev-python/pytest-sugar/pytest-sugar-0.9.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-sugar/pytest-sugar-0.9.7.ebuild')
-rw-r--r--dev-python/pytest-sugar/pytest-sugar-0.9.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-sugar/pytest-sugar-0.9.7.ebuild b/dev-python/pytest-sugar/pytest-sugar-0.9.7.ebuild
new file mode 100644
index 000000000000..2c347f622f6c
--- /dev/null
+++ b/dev-python/pytest-sugar/pytest-sugar-0.9.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Plugin that changes the default look and feel of pytest"
+HOMEPAGE="
+ https://github.com/Teemu/pytest-sugar/
+ https://pypi.org/project/pytest-sugar/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+ >=dev-python/termcolor-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest