summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtests
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest2
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.13.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index 21064283e647..edc9d772c0e7 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1,3 +1,5 @@
DIST pytest-subtests-0.12.1.tar.gz 15303 BLAKE2B 68ce29fd067836cb32b43f260c98b0a8d1827a1bf6f3f61bc98eb69a5259dad725379bece5fe745e86561cab7e58042aff7da51d39e99fd09bbf0127d04d8cca SHA512 5eb4ff950171f8e008b3879453b55bab1ebc82ec60ca4da839158ad6e195c03f1a5d6b6ce2ac263a3ecaa2f684955e4fcc7abf5e429de9ffd898586b758e6cd4
+DIST pytest_subtests-0.13.0.tar.gz 15842 BLAKE2B 8ca2b7eb9983bc8d07d2e1eff281b0047b8a8002eff7aa916e58927522eb390c2e6fd8f788738d5a5ae725bb93cd7f8f4e99eca0270d76b64a2d55f2f3c37d8f SHA512 0cff25633782e898594fab2de7078ef0d3983d5fd5ec35179e8016905f2d795024fd7c430aad42c3889f4c3f28947a4bdb93de7fad2dd9fec2d721c0fd51d323
EBUILD pytest-subtests-0.12.1.ebuild 941 BLAKE2B 9ab073bb001132ff680a3686814dfbe4c6adff5c838b9e6f340c9b1ead7decef33d81a0d64de70e949fc01cb22fc834ce59538973141936083ffb86b89b5ba6f SHA512 b58d569df445189f1770c3c77dd5c6a3f500ea8e01520a983b4e847293fa5d15a6cd2bd6838886b87af310cd21a435e95aec270230b570210884bc5191169bd7
+EBUILD pytest-subtests-0.13.0.ebuild 929 BLAKE2B 00d7e4c80f585350381a2e59d724e5f633dae13603b2dc5c66f4aecb891ee8ad2440ff00e0ebd84f3ca550b167a989747807a2d8502928318056c6d5fb5874a4 SHA512 cc32a94ab12d7d415906c238621c2107414131775a1a6e26af4361e3ac166f09edef10cf041c09c7e58b8bac01d3b36ab41c6700ef7c888a52f3f64043a21597
MISC metadata.xml 409 BLAKE2B ca267dc80fa124c3c8ba82f5e46356492e8cadefcf8001469c3c076b079844ae72829b5b527658bea341c3fee3f173421c9f2e7ec7042a171e234070113f4734 SHA512 57c12735a910107b53dbe54969f15ce70eafda3df096c78082d91d5bedc53b015ecae3e3d901e0a2a90841370916f6e4e94041e0b5589ffdce323144375e6c20
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.13.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.13.0.ebuild
new file mode 100644
index 000000000000..477c42560e40
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_subtests.plugin
+ epytest
+}