summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtests/pytest-subtests-0.12.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-subtests/pytest-subtests-0.12.0.ebuild')
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.12.0.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.12.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.12.0.ebuild
deleted file mode 100644
index d97c208fa7e5..000000000000
--- a/dev-python/pytest-subtests/pytest-subtests-0.12.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Unittest subTest() support and subtests fixture"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-subtests/
- https://pypi.org/project/pytest-subtests/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- <dev-python/pytest-8.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-7[${PYTHON_USEDEP}]
-"
-# pytest-xdist is used to test compatibility
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=xdist.plugin,pytest_subtests.plugin
- epytest
-}