summaryrefslogtreecommitdiff
path: root/dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild')
-rw-r--r--dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild b/dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild
new file mode 100644
index 000000000000..a8de6b438280
--- /dev/null
+++ b/dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION=""
+HOMEPAGE="
+ https://pytest-skip-markers.readthedocs.io/en/latest/
+ https://github.com/saltstack/pytest-skip-markers
+"
+SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/pytest-tempdir[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-system-statistics[${PYTHON_USEDEP}]
+ dev-python/pytest-shell-utilities[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/setuptools-declarative-requirements[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+ sed -e "/setuptools_scm/ d" -i setup.cfg || die
+ sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
+
+ printf '__version__ = "${PV}"\n' > src/pytestskipmarkers/version.py || die
+
+ distutils-r1_python_prepare_all
+}