summaryrefslogtreecommitdiff
path: root/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-shell-utilities/pytest-shell-utilities-1.8.0.ebuild')
-rw-r--r--dev-python/pytest-shell-utilities/pytest-shell-utilities-1.8.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.8.0.ebuild b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.8.0.ebuild
new file mode 100644
index 000000000000..80338b5cac5f
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin: fixtures and code to help with running shell commands on tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-shell-utilities/
+ https://github.com/saltstack/pytest-shell-utilities/
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-shell-utilities/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.1.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-22.1.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}