summaryrefslogtreecommitdiff
path: root/dev-python/pytest-rerunfailures
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-rerunfailures')
-rw-r--r--dev-python/pytest-rerunfailures/Manifest2
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/Manifest b/dev-python/pytest-rerunfailures/Manifest
index 50de136d60bf..76e85615bbdb 100644
--- a/dev-python/pytest-rerunfailures/Manifest
+++ b/dev-python/pytest-rerunfailures/Manifest
@@ -1,3 +1,5 @@
DIST pytest-rerunfailures-13.0.tar.gz 20846 BLAKE2B 7fbe5b05091ec358769837cb5a3f505f2901e4cec71f311268c606b237b25199d3dddb86f81399c8222f582570d99ef12a51d020d9610ea7fe25aca0a79294fe SHA512 466da7beac4785c82362e65c2c3420a5ac7c3d52a2b0c00f67ab6b8a5c64a51fc0b2172e7308c072b28a0cb0f74e1178f94ade3b10f4ad929ddf33057c80a654
+DIST pytest-rerunfailures-14.0.tar.gz 21350 BLAKE2B bb273d77a732c0296ca041b4cbd91fd48052076e9f76839b862b03de9f448208a216483bc486f23542cd99a12ef2934a46e3ea4162ca87bfd5c0904f2d114179 SHA512 8aa23a57206b0e6af133c716517c3c96cc156cc2f86b06c0fa80e9fea2b11f32e98cfb41f6a5fb05b38bab7496258160ba42fe6ae00d7bef8024159a8ed4a3f5
EBUILD pytest-rerunfailures-13.0.ebuild 777 BLAKE2B 08d7a0bb5c1a3f17d8ca620f7cb93781cccf616bd2113604aa3ab18825749deb19f911017bcd4699e4ddbfa4bd732645506a56c1690093b5ae00b4fa42658795 SHA512 699bd22262f7431b57ffd880e7747b21af2901f9779695344b129bc0b8c965c372b764fbeb42d0eaedc43b93a9ae3017369fe9fd036f24293d8e493502479706
+EBUILD pytest-rerunfailures-14.0.ebuild 785 BLAKE2B 225ea93489311f297e70cfd8311fc227be6c1085e0766025b88aeb989e385333dcd7085e1843556f62bef8d37321e72c9da6430df8f60666d3af9196a703d2b1 SHA512 904f2cf8e3fd135a93953f28b4c1e0d7e710c089cf2ba42d47094b8a6d829bd090c3da297546df2930add5d8eb599cbae08552d3934d88fedc93bf59ce7fdfdb
MISC metadata.xml 432 BLAKE2B 3bbb0bd303a26d2a336563f187160b3b023e6d7a3a776922dee4853164d7461f395e840b2c0ba1349687d24050ccb5fd18166aeec397c9b21a1aa0e6b536b795 SHA512 f372a1f73a4dc3e60f66bd6049cddb4d8cd8fe53bebff2a6d194eb3d5872adab9b7ac226971696fb24a8d4e4744427c4d4148054fc51a94f63320d428ef80d52
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild
new file mode 100644
index 000000000000..65849a9866b2
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-rerunfailures/
+ https://pypi.org/project/pytest-rerunfailures/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ epytest
+}