summaryrefslogtreecommitdiff
path: root/dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild')
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild
new file mode 100644
index 000000000000..65849a9866b2
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-rerunfailures/
+ https://pypi.org/project/pytest-rerunfailures/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ epytest
+}