summaryrefslogtreecommitdiff
path: root/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-ordering/pytest-ordering-0.6.ebuild')
-rw-r--r--dev-python/pytest-ordering/pytest-ordering-0.6.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild b/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
index 0bd6f7293be1..25ef67eebc14 100644
--- a/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
+++ b/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -18,7 +18,11 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 sparc x86"
-RDEPEND="<dev-python/pytest-6[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-pytest-6.patch"
+)
distutils_enable_tests --install pytest
distutils_enable_sphinx docs/source