summaryrefslogtreecommitdiff
path: root/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.6.ebuild')
-rw-r--r--dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.6.ebuild b/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.6.ebuild
new file mode 100644
index 000000000000..43d0138b5f59
--- /dev/null
+++ b/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Allows you to use fixtures in @pytest.mark.parametrize"
+HOMEPAGE="
+ https://github.com/dev-petrov/pytest-lazy-fixtures/
+ https://pypi.org/project/pytest-lazy-fixtures/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_lazy_fixtures.plugin
+ epytest
+}