summaryrefslogtreecommitdiff
path: root/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild')
-rw-r--r--dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild b/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild
deleted file mode 100644
index ac7134dabd4e..000000000000
--- a/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyter-server/pytest-jupyter/
- https://pypi.org/project/pytest-jupyter/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
- >=dev-python/jupyter-client-7.4.0[${PYTHON_USEDEP}]
- >=dev-python/jupyter-core-5.7[${PYTHON_USEDEP}]
- >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
- >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest