summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpserver/pytest-httpserver-1.0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-httpserver/pytest-httpserver-1.0.8.ebuild')
-rw-r--r--dev-python/pytest-httpserver/pytest-httpserver-1.0.8.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/pytest-httpserver/pytest-httpserver-1.0.8.ebuild b/dev-python/pytest-httpserver/pytest-httpserver-1.0.8.ebuild
deleted file mode 100644
index 753ffd52d86c..000000000000
--- a/dev-python/pytest-httpserver/pytest-httpserver-1.0.8.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="HTTP server for pytest to test HTTP clients"
-HOMEPAGE="
- https://github.com/csernazs/pytest-httpserver/
- https://pypi.org/project/pytest-httpserver/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/werkzeug[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # tests from building release artifacts
- tests/test_release.py
- )
-
- epytest -p no:localserver
-}