summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild')
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild
new file mode 100644
index 000000000000..14a5b50c54aa
--- /dev/null
+++ b/dev-python/pytest-httpbin/pytest-httpbin-0.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
+HOMEPAGE="https://github.com/kevin1024/pytest-httpbin
+ https://pypi.org/project/pytest-httpbin/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpbin[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# Not includd
+RESTRICT=test
+
+python_test() {
+ PYTEST_PLUGINS=pytest_httpbin \
+ py.test -v -s || die
+}