summaryrefslogtreecommitdiff
path: root/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-forked/pytest-forked-1.6.0.ebuild')
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.6.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild b/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild
index cccc7f751ac1..3c55c44a4c2e 100644
--- a/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild
+++ b/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{9..12} pypy3 )
inherit distutils-r1 pypi
@@ -32,5 +32,15 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
+ [[ ${PV} != 1.6.0 ]] && die "Recheck the deselect, please"
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # failing due to warnings coming from pytest
+ # https://github.com/gentoo/gentoo/pull/31151
+ testing/test_xfail_behavior.py::test_xfail
+ )
+ fi
+
epytest -p no:flaky
}