summaryrefslogtreecommitdiff
path: root/dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild')
-rw-r--r--dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild b/dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild
new file mode 100644
index 000000000000..5033fc34123b
--- /dev/null
+++ b/dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin that activates the fault handler module for tests"
+HOMEPAGE="https://github.com/pytest-dev/pytest-faulthandler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="
+ >=dev-python/pytest-4.0[${PYTHON_USEDEP}]
+ <dev-python/pytest-5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}