summaryrefslogtreecommitdiff
path: root/dev-python/pytest-describe/pytest-describe-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-describe/pytest-describe-2.1.0.ebuild')
-rw-r--r--dev-python/pytest-describe/pytest-describe-2.1.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/pytest-describe/pytest-describe-2.1.0.ebuild b/dev-python/pytest-describe/pytest-describe-2.1.0.ebuild
index c7a073b000a3..f9fee20dc1ec 100644
--- a/dev-python/pytest-describe/pytest-describe-2.1.0.ebuild
+++ b/dev-python/pytest-describe/pytest-describe-2.1.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -29,5 +29,6 @@ distutils_enable_tests pytest
python_test() {
# We need to disable some plugins because tests don't like unexpected
# output
- PYTEST_ADDOPTS="-p no:flaky -p no:capturelog" epytest
+ local -x PYTEST_ADDOPTS="-p no:flaky -p no:capturelog"
+ epytest
}