summaryrefslogtreecommitdiff
path: root/dev-python/pytest-describe/pytest-describe-0.11.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-describe/pytest-describe-0.11.1.ebuild')
-rw-r--r--dev-python/pytest-describe/pytest-describe-0.11.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-describe/pytest-describe-0.11.1.ebuild b/dev-python/pytest-describe/pytest-describe-0.11.1.ebuild
new file mode 100644
index 000000000000..a875b33d9f8e
--- /dev/null
+++ b/dev-python/pytest-describe/pytest-describe-0.11.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Describe-style plugin for py.test"
+HOMEPAGE="https://github.com/ropez/pytest-describe https://pypi.org/project/pytest-describe"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-2.6.0[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # We need to disable some plugins because tests don't like unexpected
+ # output
+ PYTEST_ADDOPTS="-p no:flaky -p no:capturelog" pytest -vv || die "Tests failed under ${EPYTHON}"
+}