summaryrefslogtreecommitdiff
path: root/dev-python/pytest-custom-exit-code
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-custom-exit-code')
-rw-r--r--dev-python/pytest-custom-exit-code/Manifest3
-rw-r--r--dev-python/pytest-custom-exit-code/metadata.xml12
-rw-r--r--dev-python/pytest-custom-exit-code/pytest-custom-exit-code-0.3.0.ebuild39
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pytest-custom-exit-code/Manifest b/dev-python/pytest-custom-exit-code/Manifest
new file mode 100644
index 000000000000..55d4c17fc836
--- /dev/null
+++ b/dev-python/pytest-custom-exit-code/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-custom-exit-code-0.3.0.gh.tar.gz 11147 BLAKE2B 1ffbd021f9b637de19bccc7f6fe41048b6fc600236a29faa2e9729c814ce42c8d08ec19f29de4852ec3f82f6ec850740f5bb2c7119e047c2498edbed2c8bb6dd SHA512 6b412866d60580908d6e53829ca7c5661a7a7ff4927f014e8765315da6152c1e459b5076874a11c54f7b90e7a0480011d80d883d51f437a1780ad8442366e3a5
+EBUILD pytest-custom-exit-code-0.3.0.ebuild 773 BLAKE2B f59bf8a268837281157163fabaf8eca0a6ba5d83b2ebba9f7a24c71e671c6cea210e36a141df39746bebd8cc99da8bb5f977eb80ed655bae7dbcdffa33da7520 SHA512 ab91611f60bdd3b7bf7305e35a14798ec8e1528266dd41681399522e57a4ed063a1cbe0d35e9a461e3cc7faf65faae5e4705977c03bd12a85840844370758e90
+MISC metadata.xml 410 BLAKE2B 14ad3097a9be8542b398b87faf38a55ba8a601d0f86257bf3505cc855a3aa6e22d401a1df4603649ef6bd77dc381499175cca5a58864a6d6aa396538420470e1 SHA512 3d81563cfaed1ef43d27540922dbbab9d4b1cd606eb8754534a25e6c80c23af2ee5aff5d495518d92fce86a299ed3523ddb2ef8e2b62ac76709adaa5d91e0056
diff --git a/dev-python/pytest-custom-exit-code/metadata.xml b/dev-python/pytest-custom-exit-code/metadata.xml
new file mode 100644
index 000000000000..7205210a2a24
--- /dev/null
+++ b/dev-python/pytest-custom-exit-code/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-custom-exit-code</remote-id>
+ <remote-id type="github">yashtodi94/pytest-custom_exit_code</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-custom-exit-code/pytest-custom-exit-code-0.3.0.ebuild b/dev-python/pytest-custom-exit-code/pytest-custom-exit-code-0.3.0.ebuild
new file mode 100644
index 000000000000..9e5a9c834bf5
--- /dev/null
+++ b/dev-python/pytest-custom-exit-code/pytest-custom-exit-code-0.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+inherit distutils-r1
+
+MY_PN=${PN//-/_}
+MY_PN=${MY_PN/_/-}
+
+DESCRIPTION="Exit pytest test session with custom exit code in different scenarios"
+HOMEPAGE="
+ https://pypi.org/project/pytest-custom-exit-code/
+ https://github.com/yashtodi94/pytest-custom_exit_code
+"
+
+SRC_URI="https://github.com/yashtodi94/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests
+}