summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild')
-rw-r--r--dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild b/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
index 61bbc23db863..50a1d98287f1 100644
--- a/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
+++ b/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
@@ -33,6 +33,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.0-pytest-xdist-2.5.0.patch
+)
+
distutils_enable_sphinx docs \
dev-python/sphinx-py3doc-enhanced-theme
distutils_enable_tests pytest