summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild')
-rw-r--r--dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild b/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
index 50a1d98287f1..56d8ce2bc1bb 100644
--- a/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
+++ b/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
@@ -53,9 +53,12 @@ python_test() {
tests/test_pytest_cov.py::test_contexts
)
+ local src=$(
+ "${EPYTHON}" -c "import coverage as m; print(*m.__path__)" || die
+ )
# TODO: why do we need to do that?!
# https://github.com/pytest-dev/pytest-cov/issues/517
- ln -s "${BROOT}$(python_get_sitedir)/coverage" \
+ ln -s "${src}/coverage" \
"${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
epytest