summaryrefslogtreecommitdiff
path: root/dev-python/pytest-codeblocks
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-codeblocks')
-rw-r--r--dev-python/pytest-codeblocks/Manifest2
-rw-r--r--dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-codeblocks/Manifest b/dev-python/pytest-codeblocks/Manifest
index 13eff76662c5..06898c91eb6a 100644
--- a/dev-python/pytest-codeblocks/Manifest
+++ b/dev-python/pytest-codeblocks/Manifest
@@ -1,3 +1,5 @@
DIST pytest-codeblocks-0.16.1.gh.tar.gz 8900 BLAKE2B 1e884f445975c4c685e763560a8bb5516bd7213b09a8c967948347e455816766dccfd0984fb5746949f90afdf00e0fe21a52f41be65933532d8763ed6ea716a1 SHA512 4c3d91488550373832c8dd45b39873ae3810b423147b3b9524afc8e205605324092b4462b62acf2e34e70b5456795834cae511d9c9a06e08288a46cdb38b1778
+DIST pytest-codeblocks-0.17.0.gh.tar.gz 9104 BLAKE2B 50f6d7cdf0c2d355c91a1a518622f65c4520a4e655d9c6aae64b0ea7697cf2605f37cf070fc9b7c60c2aef655b5a9adacd5acf4dbfbca2ccb8224316733dc269 SHA512 20044f10e997fbe15a8389aebdad324c2b102a11287315c8c85042f5497f51723c030b918f0cd923beb9f0c5b33a41673426a8c550814e1bd8b9b5476dd0dbf5
EBUILD pytest-codeblocks-0.16.1.ebuild 631 BLAKE2B 74c938c43bbf26cb5fceaac3baf19b72ff24c595ca1f74bd8eab9f5b1a4b2b413dd82c6b9935890c4b3d7d2740869c3ad78d6c04d9cc537e377781cc7c6fb0ef SHA512 1cd6d499d4161e90d84950bf1ee19c914bfe81cd0d5c1bb68a26d8cf21c08866f07eb187e616d6323f165a8d21e76f7bc280dde8e0a852bbdd503bb29a843cd2
+EBUILD pytest-codeblocks-0.17.0.ebuild 632 BLAKE2B fe43c80a68379308871bd406480ca00e5a2970f7d9f7d732e85b0d40c65e5056403cffd44593c5b2ca4a96b45f3943aa108f9f6e2c1537934fc00e7986b03add SHA512 91885dc8ecdc8b9799d5ae28f850af17322f0946f81a16caa37c35c7cb6b9c73e5fad2ac7c79ccbdc3d6d372a27b9a87fb3299cd957f383b1963e71d67f13d33
MISC metadata.xml 410 BLAKE2B 4e891952e8175ddd34616a0b9d4fe3baea93fee131fffea213d48db70d2dddc29400ef58c0a965cf2f310eb613a5d965827987c25392e9f294441d48589b386f SHA512 d140d21dab7f8faf8ed951d338115e8796beea0a739c00d3e9b80bef3214690ec35645ab3c3de34ff89eb63f830bce0061334cdf6092db036206698d410dcfc0
diff --git a/dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild b/dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild
new file mode 100644
index 000000000000..b11ae43d789e
--- /dev/null
+++ b/dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="
+ https://github.com/nschloe/pytest-codeblocks/
+ https://pypi.org/project/pytest_codeblocks/
+"
+SRC_URI="
+ https://github.com/nschloe/pytest-codeblocks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p pytester
+}