summaryrefslogtreecommitdiff
path: root/dev-python/pytest-bdd
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest2
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-7.2.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index de644ca88b6c..005743d68aab 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,3 +1,5 @@
DIST pytest-bdd-7.1.2.gh.tar.gz 81260 BLAKE2B 5120a79a5c085976f379afbd4ae7bc68c0d07a8517b6653bb2c94407b9964cd3adcfc92e8abc31cb658caa5c108e0590913c13cbcc408021841b91dbf52b8124 SHA512 7630b119649502e36d7ae2b6027c11b667513eab451511104076617e50de1456ee4b2ff128254ac0db630556258704e21e2a5e73ce9afc20ed403d0186c0a226
+DIST pytest-bdd-7.2.0.gh.tar.gz 81301 BLAKE2B e47ec5873546596e913453f86d7c0654b8212de74b0bfa46022da093fa87191c9303559ec670bd37f94e282973192596c77a1f7293a608ae8dedbd863fc245c2 SHA512 d0991feb446f264f0f114693dccb67682a10a427cb5fda28dccafd67cc37810e00c34e3235bb38d02b7fa1edabf1359c6c119be9cfdce0ccf00235ca3dde337b
EBUILD pytest-bdd-7.1.2.ebuild 1044 BLAKE2B 7e42bcf89034914fe6841bcf39d6e687e4d9d6ee160f43b04f66f191eaedd6f707eed65f3de97df6f4bb3367b7acb5ef3c2b173c8b525e8c97ec8b3d0ceb6d55 SHA512 48e68f5be29dffeecfcdc3a2a667b6bdda43fe67d4a9e08e2f8e492fe8c2dd73a221665013b361b57014bf52e8fb5b96c85cdea569bfc40316bf8dd40775c473
+EBUILD pytest-bdd-7.2.0.ebuild 1046 BLAKE2B f0266b1cb2a910cf19d1f073e3b68152a940d4dbecccfef802796a16d064b0094531e8c5af74834032603845b86b4d7d54bcc8069b24f2ac55a6035de3ebcc91 SHA512 06f5de0a6f741d143447c6e163a97459cab90487f245d7da163fcc0b50ce55931f41efcdc676b54f65b07375f0c2262129dd29c2d5ba84827ff1d33aeb3f7155
MISC metadata.xml 404 BLAKE2B b5bdea28ab998a54bd0b76e38c37a77af74d4ae149bfc5af47e7466b7c13ae6a5784be0ecc3e6cd8ccbbd5164dea02d704f596b7e00d22b0d640c4ad3dd13b41 SHA512 97800a5877bd8f3aa880a0cdff19cc89de983ec1a0cd9fbe2c74178b6fc214a0ca7fbb013b2ac490e1c4109f03ded7055e1517a3b57f6da0d79c9f5ea5864e77
diff --git a/dev-python/pytest-bdd/pytest-bdd-7.2.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-7.2.0.ebuild
new file mode 100644
index 000000000000..4d8f0c35dffb
--- /dev/null
+++ b/dev-python/pytest-bdd/pytest-bdd-7.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="BDD library for the pytest runner"
+HOMEPAGE="https://pytest-bdd.readthedocs.io/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/parse_type[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst )
+
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
+ distutils-r1_src_test
+}