summaryrefslogtreecommitdiff
path: root/dev-python/pyspelling
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyspelling')
-rw-r--r--dev-python/pyspelling/Manifest2
-rw-r--r--dev-python/pyspelling/pyspelling-2.10.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pyspelling/Manifest b/dev-python/pyspelling/Manifest
index 4e6fc4fa8991..91f8e02eb820 100644
--- a/dev-python/pyspelling/Manifest
+++ b/dev-python/pyspelling/Manifest
@@ -1,3 +1,5 @@
+DIST pyspelling-2.10.gh.tar.gz 152528 BLAKE2B 47ef182fb09bc3ec44b6c15da76f0d53266276ec807036378a3f5ae94daf98d3b3a49995ce2d12044c81743ee76d8b79547d84ae3c820be1f30161c75a654ba4 SHA512 dfe0d0c211555331dd6d97e06ce64ac2efbe5cc6172f684ca3b1802a8454b957781022375a9a53a2f522f4bd3bbf4e5892ab6be266bcfbe69c4861d95db00ab0
DIST pyspelling-2.9.gh.tar.gz 151600 BLAKE2B c706767917e9ba3368f9670a492a2233b6a4c13c4dde6a594a06193d856b3fbad007988acb27486b8b8f62edfeb5a0b030ead3db712baa24b0ff3301cf776937 SHA512 b14d29dff4f7791d9223d20b490f4a48ba5a6a7613dc18fc3083a3b6bf810f9a42fcac94bfe72f92023802fc8c1fe0e6432d491af2f274a138ddc56db5550ea5
+EBUILD pyspelling-2.10.ebuild 1642 BLAKE2B ac9bb2d8ac32503e63db23a8477619e4881947c2488e3bda9749efa6416151a1ef3f98e4705159916e849790bf44cf9faecd04e809055e160b11a5cca6a930c2 SHA512 73b613e9f740d0bc0db5230d2c7499eebe92f551642ab79d4e4b2ae504d9605c937c56d0577b3a91beaf76f4ec09ecda20eb8136cccb725576ca010109ad74b5
EBUILD pyspelling-2.9.ebuild 1639 BLAKE2B 19e9cde120bf3d1050d25e091064c278e1dc7ad7f6ee90d8e0fd44aef1717a7aa42538c696b5100df6c3c5d72251c30d3859e1a0a82533f6ae9e19a2802b7c38 SHA512 6ad89de977f9ad97f2e6ddf40f49d6cd7cffb549b88bf14484c8941ee2730153a43db95d7e0d8800d5345512c9f6a67dfefe16824a64664b5f52959ac5c787a5
MISC metadata.xml 1905 BLAKE2B a858329db667aaa17a8eb8d9e8b7f40e0fd8e08131420f9437e9b1fc287320f8307a801540a10c9d8625ed47b78ffee1afe1e7d083cf0a56b4f818c33356a98b SHA512 de4483bfe4595aba0478f103752e8c43748310b0643113a27b3054d19c27635367fced5283b239bc1d989e1d47ce1d5bd0babc27da283f970d4d116d36f7b9ab
diff --git a/dev-python/pyspelling/pyspelling-2.10.ebuild b/dev-python/pyspelling/pyspelling-2.10.ebuild
new file mode 100644
index 000000000000..15d322559263
--- /dev/null
+++ b/dev-python/pyspelling/pyspelling-2.10.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ >=dev-python/mkdocs-pymdownx-material-extras-2.1
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Spell checker automation tool"
+HOMEPAGE="
+ https://github.com/facelessuser/pyspelling/
+ https://pypi.org/project/pyspelling/
+"
+SRC_URI="
+ https://github.com/facelessuser/pyspelling/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ || ( app-text/aspell app-text/hunspell )
+
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/soupsieve-1.8[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-6.5[${PYTHON_USEDEP}]
+"
+# The package can use either aspell or hunspell but tests both if both
+# are installed. Therefore, we need to ensure that both have English
+# dictionary installed.
+BDEPEND="
+ test? (
+ app-dicts/aspell-en
+ app-dicts/myspell-en
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init -q || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -q -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}