summaryrefslogtreecommitdiff
path: root/dev-python/pysmi/pysmi-0.3.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysmi/pysmi-0.3.4-r1.ebuild')
-rw-r--r--dev-python/pysmi/pysmi-0.3.4-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pysmi/pysmi-0.3.4-r1.ebuild b/dev-python/pysmi/pysmi-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..22bf1f08d3dc
--- /dev/null
+++ b/dev-python/pysmi/pysmi-0.3.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2017-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python Lex & Yacc"
+HOMEPAGE="
+ https://github.com/etingof/pysmi/
+ https://pypi.org/project/pysmi/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pysnmp[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs/source