summaryrefslogtreecommitdiff
path: root/dev-python/pyserial
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyserial')
-rw-r--r--dev-python/pyserial/Manifest4
-rw-r--r--dev-python/pyserial/pyserial-3.2.1.ebuild44
-rw-r--r--dev-python/pyserial/pyserial-3.4.ebuild2
3 files changed, 2 insertions, 48 deletions
diff --git a/dev-python/pyserial/Manifest b/dev-python/pyserial/Manifest
index 3543750d5cd6..578f080826fa 100644
--- a/dev-python/pyserial/Manifest
+++ b/dev-python/pyserial/Manifest
@@ -1,6 +1,4 @@
AUX mapping.patch 495 BLAKE2B f9a2493c2ed0f522000b2ddc774c931138adda0c7d6f8d53875532fed631936436f5ec8cd572e8fc47bf5d9ada2663efdd315d6102cc5ec873d198a53c75a604 SHA512 2a0a86462291ecd78d06c9b88e8971502a58efa61ad9d47f0df2c94240245a41e7bbf9bfbd93e7761560a16fe15203cf8c5c52eaf3eb24e1499b00dfec3808f8
-DIST pyserial-3.2.1.tar.gz 147338 BLAKE2B 6c377d1527183fc48e1369f206f409d312e4488bdb15ae1d1ed93249073ffc56529a9e6059ef57c8f2ebb867cb6d9c0b7dc3a74eafbf653463a05e603b25d69c SHA512 8d3e580cc7781fc6549ab6e408642f4321eb90aafbe593f5dcf953001730f89ee32ce6592728764027a7944bfe4a0ebe2cfac1fce071777aac7c4f27ac94ab7f
DIST pyserial-3.4.tar.gz 151657 BLAKE2B cf47aba4a6f3bb2fe39d99e72907496faa1c9f37857810fef4d826cca72c361d0e43dbc33d9cf2291a589bf0193d17355d149e6eb61b4f9e28250207708ef09a SHA512 d71dffc330704e41caac6054adf192bee2f1c119691faf2ea93fe22e8e3ba000dc4a1434293f6f80d05a5577d85b96791f656e28d5c63fb0ce6a6605467a117f
-EBUILD pyserial-3.2.1.ebuild 1108 BLAKE2B f538979b8d3cf0c5ebb219a93c4c98891cb5ce9558712b912b347c5e2133271cc7452f7344ae098a0cfdf22e2c19b94f229898758bf27c249d2b0153b73f5025 SHA512 b4b9f6fcce7c5b12fc61ff7decd0f99ead2c9a0115a40f615aeffbe6a74b2ab089a010dd37d52e3104827acaf627d3ec9e1644e8b374cd59559de9c0ef46917b
-EBUILD pyserial-3.4.ebuild 889 BLAKE2B bc0b14db097ec9a743bb4837b54fdf4d3af5ccaaa2fe71002404b15d4df75f7452c63e57de49051668503d92be08c0dbbabed3227282c1239223837ade469bf3 SHA512 b857691aa348b52d595ae1422d1c38f38ea815edb5355681ebfe4f3f37b0b79358f660abbac718745a1c740692ea47608b581aacba067476428c7f9e2f9cd0a4
+EBUILD pyserial-3.4.ebuild 878 BLAKE2B 0ee38020a2985d469f5f36df16c0b2a85b7c0ba7a598d06b8e260bae0a2b5bdebf9c633eafcc2bed32950f2df6aa3ec44988bc79da36d984e3b886ccab34ba5f SHA512 971d7ceb3c61c2f2bf0f620d090cd66603318ba1b2624d951c26a60c0e88abfd8fa19d9cc7029e8329560df942309c5c5f13ab624b31ba526fc0d297a1d5df09
MISC metadata.xml 421 BLAKE2B f3c94b0b72c3df17d9c539e8b76e1f644e0b4ae1bb3d905652b568084e449bf11cab07f27e7775031eee857095671debd28bf1d2eb8c1992c6b980620b32109b SHA512 30c1232aed930c665c2603443cbff9efbb843b1866d6a4d034a517e0669f28f1e6e7562103a8badbd8fb1efd9e69b058870b9c4fcea8fa5e74e7a1ec8ba17fde
diff --git a/dev-python/pyserial/pyserial-3.2.1.ebuild b/dev-python/pyserial/pyserial-3.2.1.ebuild
deleted file mode 100644
index 2e7cc8001cbf..000000000000
--- a/dev-python/pyserial/pyserial-3.2.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Serial Port extension"
-HOMEPAGE="https://github.com/pyserial/pyserial https://pypi.org/project/pyserial/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
-IUSE="doc examples"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-# Usual avoid d'loading un-needed objects.inv file
-PATCHES=( "${FILESDIR}"/mapping.patch )
-
-DOCS=( CHANGES.rst README.rst )
-
-python_compile_all() {
- use doc && emake -C documentation html
-}
-
-python_test() {
- ${EPYTHON} test/run_all_tests.py || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( documentation/_build/html/. )
- distutils-r1_python_install_all
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/pyserial/pyserial-3.4.ebuild b/dev-python/pyserial/pyserial-3.4.ebuild
index 470d2166eded..d1032630f810 100644
--- a/dev-python/pyserial/pyserial-3.4.ebuild
+++ b/dev-python/pyserial/pyserial-3.4.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="PSF-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
IUSE="examples"
BDEPEND="