summaryrefslogtreecommitdiff
path: root/dev-python/pyrtf
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyrtf')
-rw-r--r--dev-python/pyrtf/Manifest3
-rw-r--r--dev-python/pyrtf/metadata.xml11
-rw-r--r--dev-python/pyrtf/pyrtf-0.45-r2.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyrtf/Manifest b/dev-python/pyrtf/Manifest
new file mode 100644
index 000000000000..1e727c21ae2b
--- /dev/null
+++ b/dev-python/pyrtf/Manifest
@@ -0,0 +1,3 @@
+DIST PyRTF-0.45.tar.gz 32837 BLAKE2B b6ec2ba832f0d7e84cc4de525c260191aec04156d22ccfe2e710110ae3f678f5cb119e08eba04aaa626b4c22cf343e31541ea7baca343f7bb9ea11fd80351397 SHA512 d07478ba7db6d3ef3e6c1925a58fb50b18936fecc4562338dd5b05d23672a4509a719b657a5b9e60bab5351f2be77551354fc9b856d7a9d3d4539733b05ab360
+EBUILD pyrtf-0.45-r2.ebuild 557 BLAKE2B e4b08e60d2a4989a32b51c3441d512bb563ceeae461d9a8a06fdd3bd368e1802cc7873fdbd14c915c710e42d1509a8670561e388fac52eeabc56705d5e3ef509 SHA512 c667665178ffa40976a1cab648867aa1a533a2f344b6d7644ed5e5f04d78dfbd8153592828a7fc92762bf2837e072c627596346e1ab7685a6061fb8093a81c0e
+MISC metadata.xml 315 BLAKE2B fa1074dd45945b5de27570552075e8fda68cd109ab281f0f04dad9338563f4a8badb8b76389e13cfacc41367727e804d94da87fa6ac37f7d11f4c02877c86897 SHA512 6fd0624545f5bf55ad8ab2c227baa026f0f877619167dbd99df1d5cf0e2929dc687b30b699303b05381449343a85fae5e72395ee4233f1be9a242302d233e3b9
diff --git a/dev-python/pyrtf/metadata.xml b/dev-python/pyrtf/metadata.xml
new file mode 100644
index 000000000000..05ae47510e59
--- /dev/null
+++ b/dev-python/pyrtf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pyrtf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyrtf/pyrtf-0.45-r2.ebuild b/dev-python/pyrtf/pyrtf-0.45-r2.ebuild
new file mode 100644
index 000000000000..a8cd7f64ebca
--- /dev/null
+++ b/dev-python/pyrtf/pyrtf-0.45-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="PyRTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python library to produce RTF documents"
+HOMEPAGE="http://pyrtf.sourceforge.net https://pypi.org/project/PyRTF/"
+SRC_URI="mirror://sourceforge/$PN/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"