summaryrefslogtreecommitdiff
path: root/dev-python/pyrqlite/pyrqlite-2.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyrqlite/pyrqlite-2.1.1.ebuild')
-rw-r--r--dev-python/pyrqlite/pyrqlite-2.1.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pyrqlite/pyrqlite-2.1.1.ebuild b/dev-python/pyrqlite/pyrqlite-2.1.1.ebuild
new file mode 100644
index 000000000000..d933752383b0
--- /dev/null
+++ b/dev-python/pyrqlite/pyrqlite-2.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for rqlite"
+HOMEPAGE="https://github.com/rqlite/pyrqlite"
+SRC_URI="https://github.com/rqlite/pyrqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( >=dev-db/rqlite-6.7.0 )"
+RESTRICT+=" !test? ( test )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e "s:^__version__ = .*:__version__ = '${PV}':" -i src/${PN}/constants.py || die
+ distutils-r1_src_prepare
+}