summaryrefslogtreecommitdiff
path: root/dev-python/pyroute2/pyroute2-0.7.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyroute2/pyroute2-0.7.6.ebuild')
-rw-r--r--dev-python/pyroute2/pyroute2-0.7.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyroute2/pyroute2-0.7.6.ebuild b/dev-python/pyroute2/pyroute2-0.7.6.ebuild
new file mode 100644
index 000000000000..08784a0ce549
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.7.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="
+ https://github.com/svinota/pyroute2
+ https://pypi.org/project/pyroute2/
+"
+
+LICENSE="|| ( GPL-2+ Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+# tests need root access
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"