summaryrefslogtreecommitdiff
path: root/dev-python/pyro/pyro-4.79.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyro/pyro-4.79.ebuild')
-rw-r--r--dev-python/pyro/pyro-4.79.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/pyro/pyro-4.79.ebuild b/dev-python/pyro/pyro-4.79.ebuild
deleted file mode 100644
index 9e1e384627f9..000000000000
--- a/dev-python/pyro/pyro-4.79.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-MY_PN="Pyro4"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Distributed object middleware for Python (RPC)"
-HOMEPAGE="https://pypi.org/project/Pyro4/
- https://github.com/irmen/Pyro4"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="amd64 ~arm64 ppc x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- !dev-python/pyro:0
- >=dev-python/serpent-1.27[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/cloudpickle-1.2.1[${PYTHON_USEDEP}]
- dev-python/dill[${PYTHON_USEDEP}]
- >=dev-python/msgpack-0.4.6[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Disable tests requiring network connection.
- rm tests/PyroTests/test_naming.py || die
- sed \
- -e "s/testStartNSfunc/_&/" \
- -i tests/PyroTests/test_naming2.py || die
-
- sed \
- -e "s/testBroadcast/_&/" \
- -e "s/testGetIP/_&/" \
- -i tests/PyroTests/test_socket.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/. )
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}