summaryrefslogtreecommitdiff
path: root/dev-python/pyqtgraph
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/Manifest2
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.13.4.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
index 37dcae1fadd6..1f1896d5adf0 100644
--- a/dev-python/pyqtgraph/Manifest
+++ b/dev-python/pyqtgraph/Manifest
@@ -1,3 +1,5 @@
DIST pyqtgraph-0.13.3.gh.tar.gz 1423224 BLAKE2B 6c054e243a95387f18c7f18a1d4375fac3a7ae3794902f72e8d75eaeea01e031422abb7bbd84bb94977c6ce14664fed4f66ebd9892f4200c3b3ccdd598ccbfd2 SHA512 a397fcf8fc2fcc5a212df9f4cd48dc07bc1ad9eb7a9b1283488eb52c236e054b01df02d04088a9d91679c4ae3ab7796cdf95cdbad06a6a585fbbcdb921f33617
+DIST pyqtgraph-0.13.4.gh.tar.gz 1438293 BLAKE2B aaa1ccdf318dfdee0dfee73f8f7be99897d58114971569eb14cd9e32f404cabe08edf20e78301152ad9663bda0d1e8c589ff6af63799bfdc87dfe12ab3ac5a63 SHA512 9c5c276d1e191bbb72ce1ce66fcf2cfe34f5f31318bbc3069c634a77b0373b2df6a7572eccb3cfec9a45d225f5f5da71d6ca9db3f9ef520eaab27b76176a8904
EBUILD pyqtgraph-0.13.3.ebuild 1769 BLAKE2B 2e1ee59e028577ada141ebef902eb833f4fe4b5a8e4bda3659414614c0e3e39fc8456d95c143fc6cb8dd02cae1023a1c3c3feffeeecc9de6ad8f1dfe6192efd3 SHA512 98752b3846cb747d76bf6a999dabf3b830671b2aa2093924a522ab654336ca0f6793bb9be07a408f735d1c829b47aa0135be910424dec694b8c450326e86eed9
+EBUILD pyqtgraph-0.13.4.ebuild 1817 BLAKE2B 91b2c9e18af072cc4522919958497e581851cd36d2e6a93cb8e887b1f9f400e9874f54bde93e5197ceffce16c0892cf18ce70fdd63ae8f42596b54a564fc6038 SHA512 ce9b5efc69c0d372c74a9a1d2f95c8aaeaeb6420f45e8ed83a14b1c72cb63047dd517d4d62163cdd73bd489fa3be04f241fa6849ff428b983707178b5227bc8c
MISC metadata.xml 775 BLAKE2B 08f1417793ef0b57d978cab5b4c03e43e756a43625d8e6173a8b74d3c9dcce0547934485d192546cf81b8da03bdf21e4c800bb25e0bec452fe092ab3772a518f SHA512 b03a0aa3f6e6183ef2d81b9d0bb22f576661b353986a802f01cb670f9ae0487d84d3e91fd0a4add41e3dd830dbbc0414f4d556bc05bb89a768be9e5c2cee4ce4
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.13.4.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.13.4.ebuild
new file mode 100644
index 000000000000..7f4e943402a5
--- /dev/null
+++ b/dev-python/pyqtgraph/pyqtgraph-0.13.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
+HOMEPAGE="
+ https://www.pyqtgraph.org/
+ https://github.com/pyqtgraph/pyqtgraph/
+ https://pypi.org/project/pyqtgraph/
+"
+SRC_URI="
+ https://github.com/pyqtgraph/pyqtgraph/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="opengl svg"
+REQUIRED_USE="test? ( opengl svg )"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,widgets,opengl=,svg=,${PYTHON_USEDEP}]
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/PyQt5[testlib,${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pytest-xvfb[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ if ! use opengl; then
+ rm -r pyqtgraph/opengl || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # apparently fragile
+ tests/test_reload.py::test_reload
+
+ # TODO
+ tests/exporters/test_svg.py::test_plotscene
+ tests/graphicsItems/test_ROI.py::test_PolyLineROI
+
+ # pyside2 is normally skipped if not installed but these two
+ # fail if it is installed
+ # TODO: this could be due to USE flags, revisit when pyside2
+ # gains py3.9
+ 'pyqtgraph/examples/test_examples.py::testExamples[ DateAxisItem_QtDesigner.py - PySide2 ]'
+ 'pyqtgraph/examples/test_examples.py::testExamples[ designerExample.py - PySide2 ]'
+ )
+
+ epytest -p xvfb -n "$(makeopts_jobs)"
+}